Qv2ray – 一款能媲美 Trojan-Qt5 的跨平台V2Ray客户端 | 使用插件可支持SS/SSR/Trojan/Trojan-Go/NaiveProxy等协议

Qv2ray是一款使用 Qt 框架的跨平台 V2Ray 客户端,可视化UI设计,使用起来非常方便。Qv2ray支持 Windows/Linux/MacOS系统,还可以通过
插件系统支持 SS/SSR/Trojan/Trojan-Go/NaiveProxy协议,也算是一个小全能客户端了。Qv2ray虽然比起大全能客户端Trojan-Qt5稍显逊色,但仍然是一个非常好的选择,毕竟 Trojan-Qt5 已经成为历史,作者已于2020年7月29日停止更新并删库。Trojan-Qt5支持SS/SSR/V2Ray/Trojan/Trojan-Go/Snell/NaiveProxy/http/Socks5协议,超级全能冠军,但宣告谢幕。我相信Qv2ray也会越来越强大,将来完全有希望超越Trojan-Qt5,成为新的全能冠军。

Qv2ray项目地址:https://github.com/Qv2ray/Qv2ray

Qv2ray官方文档:https://qv2ray.net/

1、Qv2ray功能特点

  • 原生支持的协议:Vmess、Vless,均是V2ray官方开发的科学上网协议;
  • 已支持的代理协议:SS(Shadowsocks)、SSR(ShadowsocksR)、Trojan、Trojan-go、NaiveProxy;
  • 图形化UI界面,方便操作;
  • 多平台支持:Windows/Linux/MacOS
  • 支持国内外流量分流;
  • 支持流量统计和重置;

2、Qv2ray客户端下载

由于某些众所周知的政策原因,Qv2ray 本身并 不包含 V2Ray 核心可执行文件。这些核心文件来自一个叫做 v2ray-core 的项目,需要用户手动下载安装到指定位置。Qv2ray 跟V2RayN一样,Qv2ray只是V2Ray客户端的GUI可视化界面程序,并不包含V2ray内核,所以在作为V2ray客户端使用时,必须先下载V2ray官方内核搭配使用。

Widnows:Qv2ray for Windows(32位) | Qv2ray for Windows(64位)

Linux:Qv2ray for Linux(64位) | Qv2ray for Debian(64位)

MacOS:Qv2ray for Mac(64位)

Qv2ray客户端最新版下载地址:https://github.com/Qv2ray/Qv2ray/releases

Qv2ray客户端和插件备份下载:下载地址1 | 下载地址2

如何为Qv2ray添加V2ray官方内核?具体操作步骤如下:

(1)Qv2ray下载完成后解压,运行其中的qv2ray.exe,之后打开Qv2ray所在目录,找到自动生成的config文件夹。

(2)在config文件夹中,新建一个文件夹,命名为”vcore”。

(3)把下载好的v2ray内核解压,将其中所有文件,移动至刚才新建好的”vcore”文件夹中。

(4)以上操作完成后,V2ray官方内核即成功添加。

注意事项:V2ray官方内核添加完成后,请确保这些文件直接存在于 vcore 目录中:

  • v2ray 或 v2ray.exe:核心可执行文件
  • v2ctl 或 v2ctl.exe:核心控制程序
  • geoip.dat:IP 规则数据库
  • geosite.dat:域名规则数据库

3、Qv2ray插件下载

默认情况下,Qv2ray只是一个V2Ray客户端程序,并不支持其它代理协议,所以你在用作其他协议的客户端时,必须配合相应的插件才行。

一个 Qv2ray 插件,技术上地说,是一个实现了 QvPlugin 接口、从而能扩展 Qv2ray 功能的共享库文件。

实际上,Qv2ray 插件是 Qv2ray 的扩展,能让你使用更多特性。

当前,Qv2ray 项目组共发布如下 6 个我们维护的插件:

QvPlugin插件下载地址:

QvPlugin-SS插件 | QvPlugin-SSR插件 | QvPlugin-Trojan插件 | QvPlugin-Trojan-Go插件 | QvPlugin-NaiveProxy插件

(1) QvPlugin-SS

QvPlugin-SS是使Qv2ray支持Shadowsocks协议的插件,使用此插件在 Qv2ray 中启用 SIP003 完整支持。

(2)QvPlugin-SSR

QvPlugin-SSR 是适用于 Qv2ray 的 ShadowSocksR 插件,使用此插件在 Qv2ray 中启用 SSR 功能。

(3)QvPlugin-Trojan

QvPlugin-Trojan是使Qv2ray支持Trojan-GFW协议的插件。

直接将插件放入Qv2ray插件目录,然后重新启动Qv2ray以重新加载插件即可使用。

(4)QvPlugin-Trojan-Go

QvPlugin-Trojan-Go 是使Qv2ray支持Trojan-Go协议的插件。

(5)QvPlugin-NaiveProxy

  • 从 Release 里下载对应版本的插件,点击下载QvPlugin-NaiveProxy插件最新版
  • 把插件放到 Qv2ray 插件目录,之后重开 Qv2ray 以加载插件
  • 进入插件管理器,选择 NaiveProxy 插件,切换到设定选项卡,把 Kernel Path 设定为 NaiveProxy 核心文件的路径。 NaiveProxy 核心文件可以在上游的 Release 中下载。Linux/macOS 用户要记得给 NaiveProxy 核心可执行权限。
  • 点击设定选项卡的测试按钮,如正常,则会显示 NaiveProxy 核心的版本。
  • 导入符合格式的连接,形如 naive+https://username:password@some.website:443?padding=true#Demo; 或者点击添加连接,手动编辑设置。
  • 双击添加的节点,大功告成。

4、Qv2ray插件安装和启用

(1)下载Qv2ray插件

(2)放置插件

  • 点击 插件管理器 窗口中的 打开本地插件文件夹 按钮,此时应自动打开一个名为 plugins 的文件夹。
  • 然后,将您所下载的Qv2ray插件文件(.dll / .dylib / .so)放入此目录。
  • 关闭 Qv2ray 并重新打开,这将让 Qv2ray 重新扫描插件目录,然后在插件菜单下就可以看到刚才添加的插件。如下图所示:

(3)启用插件

  • 打开插件管理器,你将看到所找到的插件。
  • 在插件列表中勾选所希望使用的插件即可。
  • 某些插件,尤其是核心插件(如 Trojan、ShadowsocksR 等),需要重新启动 Qv2ray 后才会生效。

5、Qv2ray常见问题答疑

(1)我可以使用Qv2ray插件吗?

要使用插件,Qv2ray 的版本至少应为 Qv2ray v2.5.0-pre1 BuildVersion: 5264,只要满足这个条件就可以。

(2)Qv2ray 没有检测到插件

  • 请确认插件位于 Qv2ray 的插件目录(config\plugins)下。
  • 请确认插件版本与 Qv2ray 版本匹配。目前,2.0.0 及之后版本的插件需要使用 Qv2ray v2.6.0-rc2 版本。
  • 如果问题仍然存在,建议直接向插件提供者进行反映。请包含下面的信息,以助开发者定位您的问题:
    • Qv2ray 的详细版本,包括在哪里下载的、具体的版本号和构建号。
    • 对应插件的详细版本,有条件的请带上插件文件的 sha256 和 md5
    • Qv2ray 的日志,可以使用 qv2ray(.exe) --debug > log.txt 命令进行收集。

(3)插件没有适合我操作系统的文件

  • 通常是插件作者懒得支持你的操作系统,或者:
  • 这个插件不适用于你的操作系统,如一个针对 Linux 系统的 iptables 设置插件可能就不适合 macOS 和 Windows。

(4)插件导致 Qv2ray 崩溃

  • 可以试试用 qv2ray(.exe) --noPlugin 禁用所有插件的加载.
  • 如果 Qv2ray 成功启动了(证明的确是插件的问题),请同上述方法报告问题。

关于 “Qv2ray – 一款能媲美 Trojan-Qt5 的跨平台V2Ray客户端 | 使用插件可支持SS/SSR/Trojan/Trojan-Go/NaiveProxy等协议” 的 2 条回复

发表评论

电子邮件地址不会被公开。 必填项已用*标注